Mikrotik Router Basic Configuration

Mikrotik Router Basic Configuration







Read More

To perform a basic configuration of a MikroTik router, follow these steps

  • Connect to the Router

Connect your computer to the MikroTik router using an Ethernet cable or through a Wi-Fi connection. Ensure that you have the necessary login credentials (username and password) to access the router.

  • Access the Router's Web Interface:
Open a web browser and enter the IP address of the router in the address bar. By default, the IP address is "192.168.88.1". Press Enter to access the MikroTik router's web interface.

  • Log in to the Router

Enter the username and password to log in to the router's web interface. By default, the username is "admin" and the password is empty (no password). If you have changed the login credentials previously, enter the updated username and password.

  • Basic Configuration Steps

Once logged in, you can start configuring the router. Here are some essential steps:

a. Change the default password:
It is crucial to set a secure password for your router to prevent unauthorized access. Go to the "System" menu, then click on "Passwords" and change the password.

b. Configure the WAN (Internet) Connection:
In the "Interfaces" menu, click on the "WAN" interface (e.g., ether1) and configure the connection type based on your ISP's requirements. It could be DHCP, PPPoE, Static IP, or other types. Enter the necessary details provided by your ISP.

c. Set LAN IP Address:
By default, the MikroTik router uses the IP address "192.168.88.1" for the LAN interface. If you prefer a different IP address range, go to the "IP" menu, select "Addresses," and modify the IP address accordingly.

d. Set up DHCP Server:
To assign IP addresses automatically to devices on your network, configure the DHCP server. Go to the "IP" menu, select "DHCP Server," and set the DHCP range and other options as per your network requirements.

e. Configure Firewall:
By default, MikroTik routers have a basic firewall enabled. You may need to adjust the firewall rules based on your network setup and security needs. Go to the "IP" menu, select "Firewall," and review or add rules as necessary.

f. Enable NAT (Network Address Translation):
If you want devices on your LAN to access the internet, you need to enable NAT. Go to the "IP" menu, select "Firewall," then click on the "NAT" tab, and enable the default "srcnat" rule.

g. Configure Wireless (if applicable):
If your MikroTik router has wireless capabilities, you can configure the Wi-Fi settings. Go to the "Wireless" menu, create a new interface, set the SSID, security settings, and other wireless parameters.

  • Save and Apply Configuration

After making the necessary configuration changes, remember to save the configuration. Go to the "Files" menu, click on the "Backup" button, and save the backup file to a secure location. Additionally, click on the "System" menu, select "Reboot," and confirm to apply the changes and reboot the router.

These steps cover the basic configuration of a MikroTik router. Remember to consult the official MikroTik documentation or seek professional assistance for advanced configuration requirements or specific network scenarios.

Basic Configuration Script


# Set the administrator password
/user set admin password="your_password"

# Configure the WAN (Internet) interface
/interface ethernet set [find name="ether1"] comment="WAN"
/ip dhcp-client add interface=ether1 comment="DHCP Client"

# Configure the LAN interface
/interface ethernet set [find name="ether2"] comment="LAN"
/ip address add address=192.168.1.1/24 interface=ether2 comment="LAN IP"

# Set up DHCP server for LAN
/ip pool add name="dhcp-pool" ranges=192.168.1.2-192.168.1.254
/ip dhcp-server add name="dhcp-server" interface=ether2 address-pool=dhcp-pool lease-time=12h

# Configure NAT (Network Address Translation)
/ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade

# Enable basic firewall rules
/ip firewall filter add chain=input action=accept connection-state=established,related
/ip firewall filter add chain=input action=drop

# Enable SSH access (optional)
/ip service set ssh disabled=no

# Enable Winbox access (optional)
/ip service set winbox disabled=no

# Enable WebFig access (optional)
/ip service set www disabled=no

# Save the configuration
/system backup save name="initial-config"

# Reboot the router to apply changes
/system reboot


To use this script, you can connect to the MikroTik router via SSH or use the Winbox application. Copy and paste the script into the terminal or text editor, then execute the script. Make sure to replace "your_password" in the first line with your desired administrator password.

This script includes basic configuration steps such as setting the administrator password, configuring the WAN and LAN interfaces, setting up DHCP server, enabling NAT, enabling basic firewall rules, and enabling optional services like SSH, Winbox, and WebFig.

Note that this is a basic script, and you may need to modify it to suit your specific network requirements. Additionally, always review and understand the configuration changes before executing any script on your router.

Click Hera Download                                      Watch Video


Network System

I configure any Wi-Fi router and internet installation.

Post a Comment

Welcome to My Blog

Previous Post Next Post
/